Document libpasswdqc-devel

This commit is contained in:
Solar Designer 2023-11-25 14:15:40 +01:00
parent 45cd03115f
commit 7afadb07a7
1 changed files with 12 additions and 3 deletions

View File

@ -1,10 +1,15 @@
# Extra package: passwdqc
## EL8 and EL9
## EL9
- Version `2.0.3-2.el9_2.security`
- Based on upstream version `2.0.3-2` as packaged in Fedora
## EL8
- Version `2.0.3-2.el8.security`
- Based on upstream version `2.0.3-2` as packaged in Fedora
### Package summary
`passwdqc` is a password/passphrase strength checking and policy enforcement toolset, including a PAM module (`pam_passwdqc`), command-line programs (`pwqcheck`, `pwqfilter`, and `pwqgen`), and a library (`libpasswdqc`).
@ -13,7 +18,7 @@ More information is available on the [passwdqc homepage](https://www.openwall.co
### Usage in Rocky Linux
There are 4 sub-packages:
There are 5 sub-packages:
#### pam_passwdqc
@ -31,6 +36,10 @@ The `pwqfilter` program searches, creates, or updates binary passphrase filter f
`libpasswdqc` is the underlying library, which may also be used from third-party programs.
#### libpasswdqc-devel
This package contains development files needed for building passwdqc-aware applications, as well as documentation (man pages) for developing such applications.
#### passwdqc
`passwdqc` is a meta sub-package that installs (via dependencies) all 3 actual sub-packages above.
`passwdqc` is a meta sub-package that installs (via dependencies) the actual sub-packages above, except for `libpasswdqc-devel`.